Service Degradation Notice – Delayed Security Event Processing

Incident Report for Kudelski Security

Monitoring

The Kudelski Security Cyber Fusion Center resumed normal security incident processing

The remaining backlog of events is currently being processed and is expected to be cleared shortly. As these events are processed, security incidents may be generated and delivered in higher-than-normal volumes.

Our Tier 1 analysts are actively triaging all incoming incidents to ensure that no security events or data have been missed during this period.

We continue to monitor the situation closely and will provide further updates as needed.

We will provide further updates as they become available.

Would you need further assistance, please ask the Cyber Fusion Center by using the MSS Portal or by phone:
North America: 1-866-929-3528
EMEA: +41 58 317 77 77
Posted Jun 22, 2026 - 15:59 UTC

Identified

Dear Valued Client,

The Kudelski Security Cyber Fusion Center experienced a service degradation due to a significant influx of SLS events, resulting in delays in the processing of security events.

The backlog is currently being processed, and delayed security events may be received in large volumes over the coming hours.

Our teams are actively monitoring the situation and working to ensure all events are processed as quickly as possible.

We will provide further updates as they become available.

Would you need further assistance, please ask the Cyber Fusion Center by using the MSS Portal or by phone:
North America: 1-866-929-3528
EMEA: +41 58 317 77 77

Kind regards,
The Cyber Fusion Center
Posted Jun 22, 2026 - 12:37 UTC
This incident affects: Security Alert / Event Ingestion Pipeline / Managed System Access.