Service Degradation Notice – Delayed Security Event Processing EMEA pipeline

Incident Report for Kudelski Security

Resolved

Dear Valued Client,

The Kudelski Security Cyber Fusion Center has resolved the service degradation performance incident.

For further assistance, please contact the Cyber Fusion Center through the MSS Client Portal or by phone:

North America: 1-866-929-3528
EMEA: +41 58 317 77 77
Posted Jul 07, 2026 - 10:04 UTC

Monitoring

Dear Valued Client,

The Kudelski Security Cyber Fusion Center has remediated the impact of the incident as of 0655h UTC.

We will continue to monitor service performance over the next two (2) hours and advise should there be any change.

For further assistance, please contact the Cyber Fusion Center through the MSS Client Portal or by phone:

North America: 1-866-929-3528
EMEA: +41 58 317 77 77
Posted Jul 07, 2026 - 07:38 UTC

Update

Dear Valued Client,

The Kudelski Security Cyber Fusion Center continues to review the situation regarding the service incident.

We will provide further updates as they become available.

Should you need further assistance, please reach out to the Cyber Fusion Center by using the MSS Portal or by phone:

North America: 1-866-929-3528
EMEA: +41 58 317 77 77
Posted Jul 07, 2026 - 05:39 UTC

Identified

Dear Valued Client,

The Kudelski Security Cyber Fusion Center has identified a service degradation due to a significant influx of events on the EMEA ingestion pipeline which may result in delays in processing.

Our teams are actively reviewing the situation and will ensure all events are processed as quickly as possible.

We will provide further updates as they become available.

Should you need further assistance, please reach out to the Cyber Fusion Center by using the MSS Portal or by phone:

North America: 1-866-929-3528
EMEA: +41 58 317 77 77
Posted Jul 07, 2026 - 02:44 UTC
This incident affected: Security Alert / Event Ingestion Pipeline / Managed System Access.