Microsoft has confirmed that the issue is related to elevated query volume and concurrency from one or more workspaces, which has resulted in backend throttling and intermittent failures of certain automation-related operations. They are actively investigating the issue and implementing mitigation measures while closely monitoring service availability.
Posted Sep 22, 2026 - 15:31 UTC
Identified
Affected Service: Microsoft Sentinel Region: East US
Impact: Customers using Microsoft Sentinel in the East US region may experience intermittent failures or delays when accessing Entity Pages and Automation Service operations.
Start Time: 22 September 2026, 10:37 UTC
Current Status: Microsoft has identified an increase in failed service requests affecting Microsoft Sentinel in East US. Initial investigation indicates the issue is related to elevated query volume and concurrency from one or more workspaces, resulting in backend throttling. Consequently, some automation-related operations may fail intermittently.
Next Update: Microsoft will provide the next update within 60 minutes or sooner if significant developments occur. Microsoft is actively investigating the issue and monitoring service health to determine the root cause and mitigation steps.
Thank you for your patience and understanding throughout this matter.
North America: 1-866-929-3528 EMEA: +41 58 317 77 77
Kind regards, The Cyber Fusion Center
Posted Sep 22, 2026 - 12:55 UTC
This incident affects: Security Alert / Event Ingestion Pipeline / Managed System Access.